Quantcast

MOPAC

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

MOPAC

Chris Swain
A user of iBabel reported that they could not convert sdf files to  MOPAC (.mop) .

I checked using the command line

 /usr/local/bin/babel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’ 

and 

/usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’

and whilst output appears in the terminal window no output file is created

Do I have the syntax wrong or something?

Cheers

Chris

------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MOPAC

Pascal Muller-3
Hi,


A user of iBabel reported that they could not convert sdf files to  MOPAC (.mop) .

I checked using the command line

 /usr/local/bin/babel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’ 

and 

/usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’

and whilst output appears in the terminal window no output file is created

Do I have the syntax wrong or something?

Try using the -O option (-O<outfilename>) e.g.
obabel tmp.sdf -O tmp.mop

Regards,
Pascal


Cheers

Chris

------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss



------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MOPAC

Chris Swain
Hi,

Thanks, that works fine.

Chris

On 15 Nov 2016, at 11:06, Pascal Muller <[hidden email]> wrote:

Hi,


A user of iBabel reported that they could not convert sdf files to  MOPAC (.mop) .

I checked using the command line

 /usr/local/bin/babel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’ 

and 

/usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’

and whilst output appears in the terminal window no output file is created

Do I have the syntax wrong or something?

Try using the -O option (-O<outfilename>) e.g.
obabel tmp.sdf -O tmp.mop

Regards,
Pascal


Cheers

Chris

------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss


------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MOPAC

mwojcikowski
Babel is deprecated in 2.4, maybe that's messing with your app?

----
Pozdrawiam,  |  Best regards,
Maciek Wójcikowski
[hidden email]

2016-11-15 12:45 GMT+01:00 Chris Swain <[hidden email]>:
Hi,

Thanks, that works fine.

Chris

On 15 Nov 2016, at 11:06, Pascal Muller <[hidden email]> wrote:

Hi,


A user of iBabel reported that they could not convert sdf files to  MOPAC (.mop) .

I checked using the command line

 /usr/local/bin/babel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’ 

and 

/usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’

and whilst output appears in the terminal window no output file is created

Do I have the syntax wrong or something?

Try using the -O option (-O<outfilename>) e.g.
obabel tmp.sdf -O tmp.mop

Regards,
Pascal


Cheers

Chris

------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss


------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss



------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MOPAC

Geoff Hutchison
In reply to this post by Chris Swain
> /usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’


The key problem is the use of the -xf flag. This is a way to set keywords in the MOPAC file by reading another file. (Useful for batch processing):

obabel *.sdf -omop -xf “keywords” -m # convert multiple files

Hope that helps,
-Geoff
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MOPAC

Chris Swain
Thanks Geoff.


> On 15 Nov 2016, at 20:18, Geoffrey Hutchison <[hidden email]> wrote:
>
>> /usr/local/bin/obabel     '/Users/Chris/Desktop/confs/temp1.sdf'  -omop  -xf '/Users/Chris/Desktop/confs/temp1.mop’
>
>
> The key problem is the use of the -xf flag. This is a way to set keywords in the MOPAC file by reading another file. (Useful for batch processing):
>
> obabel *.sdf -omop -xf “keywords” -m # convert multiple files
>
> Hope that helps,
> -Geoff


------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Loading...