[Open Babel] Cannot complie Python wrapper to the Open Babel .

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Open Babel] Cannot complie Python wrapper to the Open Babel .

fdu.xiaojf@gmail.com
I tried to compile openbabel on my debian(etch) box.
I've managed to compile penbabel successfully without even a warning.
Then I used the command "python setup.py build" to build the python wrapper.
I got  the follwing error message:
---------------------------------------------------------------------------------------------------------------------------------------------
running build
running build_py
creating build
creating build/lib.linux-i686-2.3
copying openbabel.py -> build/lib.linux-i686-2.3
running build_ext
building 'openbabel' extension
creating build/temp.linux-i686-2.3
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall
-Wstrict-prototypes -fPIC -I../../src -I/usr/include/python2.3 -c
openbabel_python.cpp -o build/temp.linux-i686-2.3/openbabel_python.o
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for
Ada/C/ObjC but not for C++
g++ -pthread -shared build/temp.linux-i686-2.3/openbabel_python.o
-L../../src -lopenbabel -o build/lib.linux-i686-2.3/openbabel.so
/usr/bin/ld: cannot find -lopenbabel
collect2: ld returned 1 exit status
error: command 'g++' failed with exit status 1
---------------------------------------------------------------------------------------------------------------------------------------------
Did I do something wrong ?

ps. The python version on my system is Python 2.3.5.

Best  wishes,



-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Open Babel] Cannot complie Python wrapper to the Open Babel .

Geoffrey Hutchison

On Oct 12, 2005, at 11:22 PM, Xiao Jianfeng wrote:

> Then I used the command "python setup.py build" to build the python  
> wrapper.
> I got  the follwing error message:

If you read the README for the Python wrapper, you'll see that you  
need to do a "make install" before you build the wrapper.  
Unfortunately, I don't know enough about the Python build scripts to  
have it search both the build directory and the standard system  
directories.

But if you run "make install" for the Open Babel library, then  
libopenbabel will be available system-wide, including for the Python  
wrapper.

Cheers,
-Geoff


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Loading...