[Open Babel] OpenBabel compilation problem on IRIX 6.5

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Open Babel] OpenBabel compilation problem on IRIX 6.5

fdu.xiaojf@gmail.com
Hello,

I'm trying to complie openbabel-2.0.0b5-20051001 on IRIX6.5.

I use the following command to configure:
./configure --without-zlib --prefix=/path/to/my/directory/local

The last part of the output is:
.....[snip]
checking for libxml - version >= 2.0.0... no
*** The xml2-config script installed by LIBXML could not be found
*** If libxml was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XML2_CONFIG environment variable to the
*** full path to xml2-config.
checking for xmlFreeDoc in -lxml2... no
checking for GetINCHI in -linchi... no
checking if zlib is wanted... no
checking for inflateEnd in -lz... no
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking zlib in /usr... failed
configure: error: either specify a valid zlib installation with
--with-zlib=DIR or disable zlib usage with --without-zlib

Note that I have disabled zlib usage with "--without-zlib" in the
configure command. Can somebody tell me what was wrong ?

Thanks a lot.

xiaojf


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: [Open Babel] OpenBabel compilation problem on IRIX 6.5

Geoffrey Hutchison

On Oct 10, 2005, at 10:37 PM, Xiao Jianfeng wrote:

> I'm trying to complie openbabel-2.0.0b5-20051001 on IRIX6.5.
>
> I use the following command to configure:
> ./configure --without-zlib --prefix=/path/to/my/directory/local

Ooh, now that's a new bug. I was using an existing ZLIB autoconf test  
and it wasn't coded correctly for --without-zlib.

I have a patched version that should solve the problem. Can I send  
you an updated snapshot to see if it fixes the problem for you?

Cheers,
-Geoff




-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss