Re: OSX 6.8 Openbabel python bindings

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: OSX 6.8 Openbabel python bindings

Visvaldas
Dear colleagues,

I tried to compile openbabel python bindings for trunk version of openbabel on December 30 on my mac, os version 10.6.8 (with python 2.5 - perhaps it's too old!), with the following error:
ng error:

{visvaldas}~/openbabel/build% make bindings_python -j2
[ 4%] [ 4%] Building CXX object src/CMakeFiles/openbabel.dir/atom.o
Building CXX object src/CMakeFiles/openbabel.dir/base.o
[ 4%] Building CXX object src/CMakeFiles/openbabel.dir/bitvec.o
[ 9%] Building CXX object src/CMakeFiles/openbabel.dir/bond.o
[ 9%] Building CXX object src/CMakeFiles/openbabel.dir/bondtyper.o
[ 9%] Building CXX object src/CMakeFiles/openbabel.dir/builder.o
[ 14%] Building CXX object src/CMakeFiles/openbabel.dir/canon.o

<similar part chopped off - VK>

[ 95%] Building CXX object src/CMakeFiles/openbabel.dir/stereo/perception.o
[100%] Building CXX object src/CMakeFiles/openbabel.dir/stereo/facade.o
Linking CXX shared library ../lib/libopenbabel.dylib
[100%] Built target openbabel
[100%] Generating ../../scripts/python/openbabel-python.cpp, ../../scripts/python/openbabel.py
/Users/visvaldas/openbabel/include/openbabel/isomorphism.h:159: Warning 325: Nested class not currently supported (Functor ignored)
Scanning dependencies of target bindings_python
[100%] Building CXX object scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o
In file included from /Library/Frameworks/Python.framework/Headers/Python.h:57,
from /Users/visvaldas/openbabel/scripts/python/openbabel-python.cpp:150:
/Library/Frameworks/Python.framework/Headers/pyport.h:730:2: error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."


make[3]: *** [scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o] Error 1
make[2]: *** [scripts/CMakeFiles/bindings_python.dir/all] Error 2
make[1]: *** [scripts/CMakeFiles/bindings_python.dir/rule] Error 2
make: *** [bindings_python] Error 2


Best regards,

Visvaldas




Hello Pierre, I've been doing some work on the Python bindings getting them to work on MacOSX 64-bit. Please try our development code (trunk). You will need to recreate the bindings using -DRUN_SWIG=TRUE with a recent version of Swig (>=2.0.1) on the path. You should also "grep -i python CMakeCache.txt" and check that all of the Python related variables are pointing to the same desired Python installation. If not, you can edit CMakeCache.txt directly or else specify the correct values when calling CMake. - Noel

------------------------------------------------------------------------------
Ridiculously easy VDI. With Citrix VDI-in-a-Box, you don't need a complex
infrastructure or vast IT resources to deliver seamless, secure access to
virtual desktops. With this all-in-one solution, easily deploy virtual
desktops for less than the cost of PCs and save 60% on VDI infrastructure
costs. Try it free! http://p.sf.net/sfu/Citrix-VDIinabox
_______________________________________________
OpenBabel-scripting mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-scripting
Reply | Threaded
Open this post in threaded view
|

Re: OSX 6.8 Openbabel python bindings

Noel O'Boyle
Administrator
Can you try using a different version of Python, e.g. your system
installation of Python. (I forget where this is located, check on
Google.)

To do this, set the CMake variables (using -D) PYTHON_EXECUTABLE,
PYTHON_INCLUDE_PATH and PYTHON_LIBRARY appropriately, and force a SWIG
rebuild by "touch $OBSRC/scripts/openbabel-python.i" (with the
appropriate value for $OBSRC). To see the current values of the Python
variables, use "grep -i python CMakeCache.txt".

- Noel

On 4 January 2012 20:58, Visvaldas K. <[hidden email]> wrote:

> Dear colleagues,
>
> I tried to compile openbabel python bindings for trunk version of openbabel
> on December 30 on my mac, os version 10.6.8 (with python 2.5 - perhaps it's
> too old!), with the following error:
> ng error:
>
> {visvaldas}~/openbabel/build% make bindings_python -j2
> [  4%] [  4%] Building CXX object src/CMakeFiles/openbabel.dir/atom.o
> Building CXX object src/CMakeFiles/openbabel.dir/base.o
> [  4%] Building CXX object src/CMakeFiles/openbabel.dir/bitvec.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/bond.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/bondtyper.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/builder.o
> [ 14%] Building CXX object src/CMakeFiles/openbabel.dir/canon.o
>
> <similar part chopped off - VK>
>
> [ 95%] Building CXX
>  object src/CMakeFiles/openbabel.dir/stereo/perception.o
> [100%] Building CXX object src/CMakeFiles/openbabel.dir/stereo/facade.o
> Linking CXX shared library ../lib/libopenbabel.dylib
> [100%] Built target openbabel
> [100%] Generating ../../scripts/python/openbabel-python.cpp,
> ../../scripts/python/openbabel.py
> /Users/visvaldas/openbabel/include/openbabel/isomorphism.h:159: Warning 325:
> Nested class not currently supported (Functor ignored)
> Scanning dependencies of target bindings_python
> [100%] Building CXX object
> scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o
> In file included from
> /Library/Frameworks/Python.framework/Headers/Python.h:57,
>                  from
> /Users/visvaldas/openbabel/scripts/python/openbabel-python.cpp:150:
> /Library/Frameworks/Python.framework/Headers/pyport.h:730:2: error: #error
> "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."
>
>
> make[3]: ***
>  [scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o]
> Error 1
> make[2]: *** [scripts/CMakeFiles/bindings_python.dir/all] Error 2
> make[1]: *** [scripts/CMakeFiles/bindings_python.dir/rule] Error 2
> make: *** [bindings_python] Error 2
>
>
> Best regards,
>
> Visvaldas
>
>
>
>
> Hello Pierre,
>
> I've been doing some work on the Python bindings getting them to work
> on MacOSX 64-bit. Please try our development code (trunk). You will
> need to recreate the bindings using -DRUN_SWIG=TRUE with a recent
> version of Swig (>=2.0.1) on the path.
>
> You should also "grep -i python CMakeCache.txt" and check that all of
> the Python related variables are pointing to the same desired Python
> installation. If not, you can edit CMakeCache.txt directly or else
> specify the correct values when calling CMake.
>
> - Noel
>
>
> ------------------------------------------------------------------------------
> Ridiculously easy VDI. With Citrix VDI-in-a-Box, you don't need a complex
> infrastructure or vast IT resources to deliver seamless, secure access to
> virtual desktops. With this all-in-one solution, easily deploy virtual
> desktops for less than the cost of PCs and save 60% on VDI infrastructure
> costs. Try it free! http://p.sf.net/sfu/Citrix-VDIinabox
> _______________________________________________
> OpenBabel-scripting mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openbabel-scripting
>

------------------------------------------------------------------------------
Ridiculously easy VDI. With Citrix VDI-in-a-Box, you don't need a complex
infrastructure or vast IT resources to deliver seamless, secure access to
virtual desktops. With this all-in-one solution, easily deploy virtual
desktops for less than the cost of PCs and save 60% on VDI infrastructure
costs. Try it free! http://p.sf.net/sfu/Citrix-VDIinabox
_______________________________________________
OpenBabel-scripting mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-scripting
Reply | Threaded
Open this post in threaded view
|

Re: OSX 6.8 Openbabel python bindings

Visvaldas
Actually, the python which I used when trying to install openbabel python bindings, was from Xcode disk. I will use fink to install another version of python. (It seems that in fink one can install openbabel-py if the the fink-version of python is downloaded, but I was hoping I could compile openbabel bindings from scratch using "native" python).
Thank you,
Visvaldas


From: Noel O'Boyle <[hidden email]>
To: Visvaldas K. <[hidden email]>
Cc: "[hidden email]" <[hidden email]>
Sent: Thursday, January 5, 2012 3:34 PM
Subject: Re: [OpenBabel-scripting] OSX 6.8 Openbabel python bindings

Can you try using a different version of Python, e.g. your system
installation of Python. (I forget where this is located, check on
Google.)

To do this, set the CMake variables (using -D) PYTHON_EXECUTABLE,
PYTHON_INCLUDE_PATH and PYTHON_LIBRARY appropriately, and force a SWIG
rebuild by "touch $OBSRC/scripts/openbabel-python.i" (with the
appropriate value for $OBSRC). To see the current values of the Python
variables, use "grep -i python CMakeCache.txt".

- Noel

On 4 January 2012 20:58, Visvaldas K. <[hidden email]> wrote:

> Dear colleagues,
>
> I tried to compile openbabel python bindings for trunk version of openbabel
> on December 30 on my mac, os version 10.6.8 (with python 2.5 - perhaps it's
> too old!), with the following error:
> ng error:
>
> {visvaldas}~/openbabel/build% make bindings_python -j2
> [  4%] [  4%] Building CXX object src/CMakeFiles/openbabel.dir/atom.o
> Building CXX object src/CMakeFiles/openbabel.dir/base.o
> [  4%] Building CXX object src/CMakeFiles/openbabel.dir/bitvec.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/bond.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/bondtyper.o
> [  9%] Building CXX object src/CMakeFiles/openbabel.dir/builder.o
> [ 14%] Building CXX object src/CMakeFiles/openbabel.dir/canon.o
>
> <similar part chopped off - VK>
>
> [ 95%] Building CXX
>  object src/CMakeFiles/openbabel.dir/stereo/perception.o
> [100%] Building CXX object src/CMakeFiles/openbabel.dir/stereo/facade.o
> Linking CXX shared library ../lib/libopenbabel.dylib
> [100%] Built target openbabel
> [100%] Generating ../../scripts/python/openbabel-python.cpp,
> ../../scripts/python/openbabel.py
> /Users/visvaldas/openbabel/include/openbabel/isomorphism.h:159: Warning 325:
> Nested class not currently supported (Functor ignored)
> Scanning dependencies of target bindings_python
> [100%] Building CXX object
> scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o
> In file included from
> /Library/Frameworks/Python.framework/Headers/Python.h:57,
>                  from
> /Users/visvaldas/openbabel/scripts/python/openbabel-python.cpp:150:
> /Library/Frameworks/Python.framework/Headers/pyport.h:730:2: error: #error
> "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."
>
>
> make[3]: ***
>  [scripts/CMakeFiles/bindings_python.dir/python/openbabel-python.cpp.o]
> Error 1
> make[2]: *** [scripts/CMakeFiles/bindings_python.dir/all] Error 2
> make[1]: *** [scripts/CMakeFiles/bindings_python.dir/rule] Error 2
> make: *** [bindings_python] Error 2
>
>
> Best regards,
>
> Visvaldas
>
>
>
>
> Hello Pierre,
>
> I've been doing some work on the Python bindings getting them to work
> on MacOSX 64-bit. Please try our development code (trunk). You will
> need to recreate the bindings using -DRUN_SWIG=TRUE with a recent
> version of Swig (>=2.0.1) on the path.
>
> You should also "grep -i python CMakeCache.txt" and check that all of
> the Python related variables are pointing to the same desired Python
> installation. If not, you can edit CMakeCache.txt directly or else
> specify the correct values when calling CMake.
>
> - Noel
>
>
> ------------------------------------------------------------------------------
> Ridiculously easy VDI. With Citrix VDI-in-a-Box, you don't need a complex
> infrastructure or vast IT resources to deliver seamless, secure access to
> virtual desktops. With this all-in-one solution, easily deploy virtual
> desktops for less than the cost of PCs and save 60% on VDI infrastructure
> costs. Try it free! http://p.sf.net/sfu/Citrix-VDIinabox
> _______________________________________________
> OpenBabel-scripting mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/openbabel-scripting
>



------------------------------------------------------------------------------
Ridiculously easy VDI. With Citrix VDI-in-a-Box, you don't need a complex
infrastructure or vast IT resources to deliver seamless, secure access to
virtual desktops. With this all-in-one solution, easily deploy virtual
desktops for less than the cost of PCs and save 60% on VDI infrastructure
costs. Try it free! http://p.sf.net/sfu/Citrix-VDIinabox
_______________________________________________
OpenBabel-scripting mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-scripting