error with complin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

error with complin

Mohammad Goodarzi
Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 

------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Fredrik Wallner
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss


------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Mohammad Goodarzi
Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`

Warning: open-babel-2.4.1 already installed, it's just not linked


any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss



------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Fredrik Wallner
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss



------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Mohammad Goodarzi
Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel

Linking /usr/local/Cellar/open-babel/2.4.1... 

Error: Could not symlink bin/babel

Target /usr/local/bin/babel

already exists. You may want to remove it:

  rm '/usr/local/bin/babel'


To force the link and overwrite all conflicting files:

  brew link --overwrite open-babel


To list all files that would be deleted:

  brew link --overwrite --dry-run open-babel



Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel

Linking /usr/local/Cellar/open-babel/2.4.1... 

Error: Could not symlink include/inchi/inchi_api.h

/usr/local/include/inchi is not writable.



I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel

Error: No such keg: /usr/local/Cellar/openbabel



Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss




------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Fredrik Wallner
Ok, the last error is that you misspelled open-babel, but that doesn’t matter. The problem in the second run is that you don’t have permissions to write in the folder /usr/local/include/inchi. My suggestion there would be to remove that directory, using sudo (sudo rm -r /usr/local/include/inchi) and try again.
29 nov. 2016 kl. 11:03 skrev Mohammad Goodarzi <[hidden email]>:

Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink bin/babel
Target /usr/local/bin/babel
already exists. You may want to remove it:
  rm '/usr/local/bin/babel'

To force the link and overwrite all conflicting files:
  brew link --overwrite open-babel

To list all files that would be deleted:
  brew link --overwrite --dry-run open-babel


Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/inchi/inchi_api.h
/usr/local/include/inchi is not writable.


I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel
Error: No such keg: /usr/local/Cellar/openbabel


Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss





------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Mohammad Goodarzi
The problem is still there 

I did remove the file 
sudo rm -r /usr/local/include/inchi

Then I tried again with brew install open-babel 
which gave me the same error to use link open-babel

Then I did 

$ brew link open-babel

Linking /usr/local/Cellar/open-babel/2.4.1... 

Error: Could not symlink include/openbabel-2.0/openbabel/alias.h

/usr/local/include/openbabel-2.0/openbabel is not writable.



I know that I must not use sudo because I can damage a lot, but i gave it a shot too, look at the error below 



$ sudo brew link open-babel

Error: Running Homebrew as root is extremely dangerous and no longer supported.

As Homebrew does not drop privileges on installation you would be giving all

build scripts full access to your system.







On Tue, Nov 29, 2016 at 11:09 AM, Fredrik Wallner <[hidden email]> wrote:
Ok, the last error is that you misspelled open-babel, but that doesn’t matter. The problem in the second run is that you don’t have permissions to write in the folder /usr/local/include/inchi. My suggestion there would be to remove that directory, using sudo (sudo rm -r /usr/local/include/inchi) and try again.

29 nov. 2016 kl. 11:03 skrev Mohammad Goodarzi <[hidden email]>:

Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink bin/babel
Target /usr/local/bin/babel
already exists. You may want to remove it:
  rm '/usr/local/bin/babel'

To force the link and overwrite all conflicting files:
  brew link --overwrite open-babel

To list all files that would be deleted:
  brew link --overwrite --dry-run open-babel


Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/inchi/inchi_api.h
/usr/local/include/inchi is not writable.


I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel
Error: No such keg: /usr/local/Cellar/openbabel


Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss






------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Fredrik Wallner
Hello again,

If you read the error from the first run to ”brew link open-babel” you will see that the error is exactly the same as bor the inchi folder before, so a good guess would be to use the same method to resolve it.

Kind regards,
Fredrik
29 nov. 2016 kl. 11:16 skrev Mohammad Goodarzi <[hidden email]>:

The problem is still there 

I did remove the file 
sudo rm -r /usr/local/include/inchi

Then I tried again with brew install open-babel 
which gave me the same error to use link open-babel

Then I did 

$ brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/openbabel-2.0/openbabel/alias.h
/usr/local/include/openbabel-2.0/openbabel is not writable.


I know that I must not use sudo because I can damage a lot, but i gave it a shot too, look at the error below 



$ sudo brew link open-babel
Error: Running Homebrew as root is extremely dangerous and no longer supported.
As Homebrew does not drop privileges on installation you would be giving all
build scripts full access to your system.






On Tue, Nov 29, 2016 at 11:09 AM, Fredrik Wallner <[hidden email]> wrote:
Ok, the last error is that you misspelled open-babel, but that doesn’t matter. The problem in the second run is that you don’t have permissions to write in the folder /usr/local/include/inchi. My suggestion there would be to remove that directory, using sudo (sudo rm -r /usr/local/include/inchi) and try again.

29 nov. 2016 kl. 11:03 skrev Mohammad Goodarzi <[hidden email]>:

Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink bin/babel
Target /usr/local/bin/babel
already exists. You may want to remove it:
  rm '/usr/local/bin/babel'

To force the link and overwrite all conflicting files:
  brew link --overwrite open-babel

To list all files that would be deleted:
  brew link --overwrite --dry-run open-babel


Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/inchi/inchi_api.h
/usr/local/include/inchi is not writable.


I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel
Error: No such keg: /usr/local/Cellar/openbabel


Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss







------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Mohammad Goodarzi
Hello Again,

I managed to do it both by compile and through brew now. 

Open Babel 2.4.1 -- Oct 12 2016 -- 00:37:03



Thanks for your support. I have one more question which is not a critical one so I ask it here.
The source code or python code of confab is available ? 

Thanks again and have a good day
Cheers,
Mohammad 



On Tue, Nov 29, 2016 at 11:18 AM, Fredrik Wallner <[hidden email]> wrote:
Hello again,

If you read the error from the first run to ”brew link open-babel” you will see that the error is exactly the same as bor the inchi folder before, so a good guess would be to use the same method to resolve it.

Kind regards,
Fredrik

29 nov. 2016 kl. 11:16 skrev Mohammad Goodarzi <[hidden email]>:

The problem is still there 

I did remove the file 
sudo rm -r /usr/local/include/inchi

Then I tried again with brew install open-babel 
which gave me the same error to use link open-babel

Then I did 

$ brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/openbabel-2.0/openbabel/alias.h
/usr/local/include/openbabel-2.0/openbabel is not writable.


I know that I must not use sudo because I can damage a lot, but i gave it a shot too, look at the error below 



$ sudo brew link open-babel
Error: Running Homebrew as root is extremely dangerous and no longer supported.
As Homebrew does not drop privileges on installation you would be giving all
build scripts full access to your system.






On Tue, Nov 29, 2016 at 11:09 AM, Fredrik Wallner <[hidden email]> wrote:
Ok, the last error is that you misspelled open-babel, but that doesn’t matter. The problem in the second run is that you don’t have permissions to write in the folder /usr/local/include/inchi. My suggestion there would be to remove that directory, using sudo (sudo rm -r /usr/local/include/inchi) and try again.

29 nov. 2016 kl. 11:03 skrev Mohammad Goodarzi <[hidden email]>:

Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink bin/babel
Target /usr/local/bin/babel
already exists. You may want to remove it:
  rm '/usr/local/bin/babel'

To force the link and overwrite all conflicting files:
  brew link --overwrite open-babel

To list all files that would be deleted:
  brew link --overwrite --dry-run open-babel


Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/inchi/inchi_api.h
/usr/local/include/inchi is not writable.


I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel
Error: No such keg: /usr/local/Cellar/openbabel


Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss








------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss
Reply | Threaded
Open this post in threaded view
|

Re: error with complin

Fredrik Wallner
https://github.com/openbabel/openbabel/blob/master/src/ops/opconfab.cpp

29 nov. 2016 kl. 12:42 skrev Mohammad Goodarzi <[hidden email]>:

Hello Again,

I managed to do it both by compile and through brew now. 
Open Babel 2.4.1 -- Oct 12 2016 -- 00:37:03


Thanks for your support. I have one more question which is not a critical one so I ask it here.
The source code or python code of confab is available ? 

Thanks again and have a good day
Cheers,
Mohammad 



On Tue, Nov 29, 2016 at 11:18 AM, Fredrik Wallner <[hidden email]> wrote:
Hello again,

If you read the error from the first run to ”brew link open-babel” you will see that the error is exactly the same as bor the inchi folder before, so a good guess would be to use the same method to resolve it.

Kind regards,
Fredrik

29 nov. 2016 kl. 11:16 skrev Mohammad Goodarzi <[hidden email]>:

The problem is still there 

I did remove the file 
sudo rm -r /usr/local/include/inchi

Then I tried again with brew install open-babel 
which gave me the same error to use link open-babel

Then I did 

$ brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/openbabel-2.0/openbabel/alias.h
/usr/local/include/openbabel-2.0/openbabel is not writable.


I know that I must not use sudo because I can damage a lot, but i gave it a shot too, look at the error below 



$ sudo brew link open-babel
Error: Running Homebrew as root is extremely dangerous and no longer supported.
As Homebrew does not drop privileges on installation you would be giving all
build scripts full access to your system.






On Tue, Nov 29, 2016 at 11:09 AM, Fredrik Wallner <[hidden email]> wrote:
Ok, the last error is that you misspelled open-babel, but that doesn’t matter. The problem in the second run is that you don’t have permissions to write in the folder /usr/local/include/inchi. My suggestion there would be to remove that directory, using sudo (sudo rm -r /usr/local/include/inchi) and try again.

29 nov. 2016 kl. 11:03 skrev Mohammad Goodarzi <[hidden email]>:

Hello, 

Yes, I have tried that. I did it again , here are the error I get

$brew link open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink bin/babel
Target /usr/local/bin/babel
already exists. You may want to remove it:
  rm '/usr/local/bin/babel'

To force the link and overwrite all conflicting files:
  brew link --overwrite open-babel

To list all files that would be deleted:
  brew link --overwrite --dry-run open-babel


Then as you also said and it is mentioned above , I did the following 

$ brew link --overwrite open-babel
Linking /usr/local/Cellar/open-babel/2.4.1... 
Error: Could not symlink include/inchi/inchi_api.h
/usr/local/include/inchi is not writable.


I thought maybe works for the second time :-D, so I restart the terminal and I did 

$ brew link --overwrite openbabel
Error: No such keg: /usr/local/Cellar/openbabel


Thanks and sorry for trouble 
Cheers,
Mo



On Tue, Nov 29, 2016 at 10:57 AM, Fredrik Wallner <[hidden email]> wrote:
The error message says that you should run "brew link open-babel". Have you tried that?

You probably have a problem with an old open-babel version in /use/local why HomeBrew will fail on linking. 

Run brew doctor to see if it warns on stuff in /usr/local, especially if there are stuff related to OpenBabel (e.g. libopenbabel, libinchi…)

If ”brew link open-babel" fails you can also try with "brew link --overwrite openbabel”. If that also fails, please provide the output of that command.

Kind regards,
Fredrik

Skickat från min iPhone

29 nov. 2016 kl. 10:44 skrev Mohammad Goodarzi <[hidden email]>:

Hello Fredrik, 

Thanks , I have tried many things before I ask. I am not getting what I really want. 

For example, I do have Homebrew 1.1.2

and when I simply run brew install open-babel , I am getting this 

You can link formula with `brew link open-babel`
Warning: open-babel-2.4.1 already installed, it's just not linked

any idea where the problem is ?

Cheers,
Mo

On Tue, Nov 29, 2016 at 10:37 AM, Fredrik Wallner <[hidden email]> wrote:
Hi,

I would suggest you go with the HomeBrew option instead.
If you don’t have HomeBrew installed, go to http://brew.sh 
Run the command from the installation instructions at openbabel.org (http://openbabel.org/wiki/Category:Installation): brew install open-babel

The error you are getting is because you are lacking cmake which is one of the requirements specified in the wiki for installing from the source code, but it is a lot easier to use the prebuilt versions form HomeBrew or Anaconda if you are not used to compiling stuff.

Kind regards,
Fredrik
29 nov. 2016 kl. 09:43 skrev Mohammad Goodarzi <[hidden email]>:

Hello,

I am trying to install open babel on a Mac machine version 10.12.1

I used the following to do it 


Here the steps I am doing

1-First I download the latest version to desktop and set my directory in terminal to desktop 
2- tar zxvf openbabel-2.4.1.tar
3-mv openbabel-2.4.1 ob-src
4-mkdir ob-build

Now on desktop I have two folder one is ob-src and the other is ob-build


5-cd ob-build
6- cmake ../ob-src 2>&1 | tee cmake.out

Then  get error as follows:

-bash: cmake: command not found 

when I do ls , there is nothing which is logical because I just created it myself 


Many thanks for your help
Mo





 
------------------------------------------------------------------------------
_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss









------------------------------------------------------------------------------

_______________________________________________
OpenBabel-discuss mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/openbabel-discuss